Degraded database performance

Incident Report for Nektar

Resolved

This incident has been resolved.
Posted Aug 29, 2025 - 02:04 MDT

Identified

Some users on certain databases may be experiencing degraded query performance, especially in relation to Telematics. Telematics ingestion is also currently delayed from Geotab. We are actively working on a mitigation and solution
Posted Aug 28, 2025 - 15:01 MDT
This incident affected: Web App, API and Mobile Apps (iOS, Android).